Logs troubleshooting

Common error messages that appear in logs and may suggest system or bot failure

📘

Troubleshooting errors that happened during a conversation?

Check out the Errors tab in Analytics module to look for more detailed info on what went wrong, where and when.

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Check Kubernetes cluster events

In case of system failure remember to check cluster events with command kubectl get events

Cannot parse (...) as a number, wrong format. Decimal point number should use '.'

Description

Expression language that is used in one of the blocks tries to convert to number empty string or other input that is not a number in US format.

Logger

chatbots.dialogManager.engine.DialogEngine

Examples

Cannot parse as a number, wrong format. Decimal point number should use '.'; block: say:addition; expression: system.userInput.toNumber()

Cannot parse 6+ as a number, wrong format. Decimal point number should use '.'; block: say:subtraction; expression: system.userInput.toNumber()

Cannot parse 500 plus as a number, wrong format. Decimal point number should use '.'; block: say:multiplication; expression: system.userInput.toNumber()

Logger

chatbots.dialogManager.engine.DialogEngine

Impact

Failure of bot in conversations that reach flawed block and user provide number in non standard way

Root cause

Wrong usage of expression language in flow configuration

Solution

  • In admin panel find block where expression is used and clean input before using method toNumber.
  • Check if you shouldn't be using system entity sys.Numeral which is designed to extract numeric values from user input.

Concurrent operations on same lock. Aborting session

Description

System is designed this way that all interaction with bot in single sessions should by synchronous - this means that you cannot make any calls to bot before previous request has ended. Calls made to bot when another request is processed in same session will be ignored and fail.

Examples

Concurrent operations on same lock. Aborting session: SynchronizationSession(-1992677230489943428,SessionLock(web_chat_202301111555_0LLTPeRh6O),AbortOnMultiAccess)

Concurrent operations on same lock. Aborting session: SynchronizationSession(-7697637035708299979,SessionLock(web_chat_202301111552_G9BH1EH5XC),AbortOnMultiAccess)

Concurrent operations on same lock. Aborting session: SynchronizationSession(-4988143900393650570,SessionLock(web_chat_202301111505_mhIXm2bYCO),AbortOnMultiAccess)

Logger

chatbots.concurrency.RedissonDistributedSynchronizer

Impact

Requests are dropped (ignored), but bot replies to requests that are sent in proper way

Root cause

Wrong usage of gateway API

Solution

  • Fix your module that is using the gateway API so that calls are synchronous

Operation property(...) is not supported by type NullValue$

Description

Expression language that is used in one of the blocks tries to get property on null (not initialized) object

Examples

Operation property(CPK) is not supported by type NullValue$; block: custom:MEMORY DATA; expression: external.outgoing_bot.CPK

Operation property(color) is not supported by type NullValue$; block: custom:Car colors; expression: memory.car.color

Logger

chatbots.dialogManager.engine.DialogEngine

Impact

Failure of bot in conversations that reach flawed block

Root cause

Wrong usage of expression language in flow configuration

Solution

  • In admin panel find block where expression is used and make sure that object variables are properly initialized and they have properties that you need to use.

Error while evaluating JS code

Description

Response returned by external API defined in Integrations module cannot be mapped to configured variables

Examples

Error while evaluating JS code LoanProducts - org.graalvm.polyglot.PolyglotException: ReferenceError: LoanProducts is not defined

Error while evaluating JS code mainIntent.name - org.graalvm.polyglot.PolyglotException: TypeError: Cannot read property 'name' of null

Error while evaluating JS code BirthDate - org.graalvm.polyglot.PolyglotException: ReferenceError: BirthDate is not defined

Logger

chatbots.integrations.ResponseExtractor

Impact

Failure of bot in conversations that use the flawed integration

Root cause

Wrong mapping of variables in configuration in Integrations module or malfunctioning external API

Solution

  • Check the external API if it returns expected response
  • Verify mapping in Integrations module

Got unexpected status when communicating with external API

Description

External API returned non HTTP 200 status code

Examples

Got unexpected status when communicating with external AP: pl.chimeo.utils.api.UnexpectedStatusException: Got response with status 400 Bad Request when calling http://some-api.com:8080/method

Logger

chatbots.gateway.controllers.BotController

Impact

Failure of bot in conversations that use the flawed integration

Root cause

Malfunctioning external API

Solution

  • Check the external API if it returns expected response
  • Contact external API provider

Exception occurred when processing request, Got error when communicating with internal API

Description

Gateway cannot connect to internal pod or this pod returns error

Examples

Exception occurred when processing request - org.http4s.client.ConnectionFailure: Error connecting to http://admin:8080 using address admin:8080 (unresolved: false)
Got error when communicating with internal API: http://gateway:5000/gateway: Error connecting to http://admin:8080 using address admin:8080 (unresolved: false)

Logger

chatbots.gateway.controllers.BotController, controllers.ChatController

Impact

Failure of all conversation with bot

Root cause

Pods are not running or are not ready when request was made

Solution

  • Determine by the address to which pod system has problem connecting to
  • Check Kubernetes events for pod restarts or other failures
  • Check logs of the flawed pod. Are other requests incoming?
  • Check connectivity and firewall rules within the Kubernetes cluster

Error when processing documents, Error while processing message in (...)

Description

NLU component that appears in the error message returned error

Examples

Error while processing message in NER - java.lang.RuntimeException: Got response with status 400 Bad Request when calling http://ner-pl:5000/predict
Error when processing documents: Error while processing message in INTENTIZER: Got response with status 400 Bad Request when calling http://intentizer-multi:6543/predict
Error when processing documents: Error while processing message in NER: Got response with status 400 Bad Request when calling http://ner-pl:5000/predict

Logger

pl.chimeo.nlu.ProcessingService, pl.chimeo.nlu.processor.service.ServiceProcessor

Impact

Failure of conversations where error appears

Root cause

Determining root cause requires advanced log analysis performed by SentiOne. Please submit support ticket with all logs attached.

Solution

  • Determine the request ID
  • Find all logs for that request ID to get message that triggered NLU error
  • Analyze logs of malfunctioning pod to determine the root cause

Error while executing csv connector

Description

CSV connector cannot read file to update the Knowledge Base

Examples

Error while executing csv connector

Logger

services.knowledgeBase.CsvConnectorExecutor

Impact

Knowledge base is not being updated automatically and current data is intact.

Root cause

File is not accessible or is not a valid CSV file (UTF-8, RFC-4180 compliant - NOT Microsoft Excel dialect)

Solution

  • Find the faulty connector in Knowledge Base -> Connectors
  • Check if the file path is proper and accessible
  • Check if CSV file is RFC-4180 compliant - Microsoft Excel dialect is not supported

Got response with status 404 Not Found when calling http://admin:8080/api/external/projects/

Description

Project with given ID does not exists or is not published.

Examples

Got error when communicating with internal API: http://gateway:5000/gateway: Got response with status 404 Not Found when calling http://admin:8080/api/external/projects/

Logger

controllers.ChatController
chatbots.gateway.controllers.BotController

Impact

Bot will not work because it looks for project that does not exists.

Root cause

There is a typo in project ID when calling gateway or embedding webchat in HTML. Project could also have been deleted, moved by bot designer or it is was not published

Solution

  • Make sure project exists and is published
  • Check project ID in webchat embedding
  • Check project ID when calling gateway API

Error occurred while calling API http://nlu-facade:5750/v2/classify

Description

One of the NLU components fails when doing classification which results in bot not responding properly to user messages.

Examples

Error occurred while calling API http://nlu-facade:5750/v2/classify

Impact

Bot does not respond properly to user messages

Root cause

In one of the NLU components there is an error which causes classification to fail

Solution

  • Check Kubernetes cluster events to see if pods are stable
  • Check logs of nlu-pipeline to find which NLU component throws this error
  • Check logs of faulty NLU component and look for error message that causes this error.
  • If you are not sure, you may want to check other NLU components include, which include intentizer, keywords, pcre, inferrer, pattern, ner, tagger, sentiduck, duckling, greetings-detector
  • Restarting NLU components in many cases provide instant fix and is safe to perform.